Skip to main content
Version: 3.0.0-beta8

Upgrade Litmus ChaosCenter to Latest Version


Upgrade ChaosCenter

To upgrade Litmus ChaosCenter from 3.0.0-beta7 to 3.0.0-beta8, you can follow these steps:

Note: This step is not required if using Helm, Helm upgrade should work.

  1. Upgrade the control plane (ChaosCenter) To upgrade ChaosCenter, you can re-apply the manifest using the kubectl.

    kubectl apply -f https://raw.githubusercontent.com/litmuschaos/litmus/master/mkdocs/docs/3.0.0-beta8/litmus-3.0.0-beta8.yaml

Upgrade Mongodb DB Schema

Note: This step is not required if using Helm, Helm upgrade should work.

To upgrade the DB schema, deploy the upgrade-agent in your k8s cluster where ChaosCenter is installed. This manifest will create a Job, which will upgrade the mongoDB schema.

kubectl apply -f https://raw.githubusercontent.com/litmuschaos/litmus/master/litmus-portal/upgrade-agents/control-plane/upgrade-agent.yaml

Upgrade Chaos Delegate

To upgrade your Chaos Delegate, you can follow these steps:

  1. If an upgrade is available, you will get an option to upgrade your chaos delegate in the ChaosCenter. Upon clicking on the upgrade option, a modal will pop up providing you the litmusctl command which you can execute and your Chaos Delegate will be upgraded.

Alternatively you can run the following command using litmusctl in the cluster containing the chaos delegate by providing <CLUSTER_ID> and <PROJECT_ID>.

litmusctl upgrade agent --cluster-id="<CLUSTER_ID>" --project-id="<PROJECT_ID>"

Note: v0.7.0 of litmusctl is required.